Problem ze środowiskiem Keli uVision

Keil uvision, IAR ...
ODPOWIEDZ
gador12
Nowy
Posty: 3
Rejestracja: 19 sty 2020, 0:18

Problem ze środowiskiem Keli uVision

Post autor: gador12 » 19 sty 2020, 0:33

Mam do wykonania projekt na płytce KL05z od firmy FREESCALE. Zacząłem od napisanie pliku nagłówkowego z funkcjami obsługującymi klawiaturę matrycową 3x4. Jednak już na etapie pisanie funkcji inicjalizującej napotkałem błędy których nie mogę rozwiązać, wydaje mi się, że kod napisany jest poprawnie(pewnie się mylę). Gdyby ktoś mógł wyjaśnić mi co robię nie tak, byłbym bardzo wdzięczny.

Awatar użytkownika
xbary
Użytkownik
Posty: 108
Rejestracja: 08 paź 2017, 19:59

Re: Problem ze środowiskiem Keli uVision

Post autor: xbary » 19 sty 2020, 0:41

Dobrze gdybyś pokazał ten kod, bo teraz można się domyślać 100 scenariuszy jakie mógłbyś popełnić :)

gador12
Nowy
Posty: 3
Rejestracja: 19 sty 2020, 0:18

Re: Problem ze środowiskiem Keli uVision

Post autor: gador12 » 19 sty 2020, 12:00

Nie zauważyłem, że nie dodałem załączników, już wstawiam kod oraz listę generowanych błędów.
errors1.png
keypad1.h.png
main1.c.png
keypad1.c.png
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.

Awatar użytkownika
xbary
Użytkownik
Posty: 108
Rejestracja: 08 paź 2017, 19:59

Re: Problem ze środowiskiem Keli uVision

Post autor: xbary » 19 sty 2020, 20:07

masz średnik za keypadinitialize(void) w keypad1.c pliku w lini 5

:)

gador12
Nowy
Posty: 3
Rejestracja: 19 sty 2020, 0:18

Re: Problem ze środowiskiem Keli uVision

Post autor: gador12 » 19 sty 2020, 22:33

Samemu już udało mi się do tego dojść ale i tak dzięki za pomoc.

ODPOWIEDZ

Wróć do „Inne środowiska”